TapFirefox 3.5 Extensions

Rather quietly, certainly without the fanfare of version 3, Firefox 3.5 was released a couple of days ago.

This is an update to my earlier post about difficult extensions bringing the version numbers and locations up to date. There are still a few that I found that could be simply hacked to enable them to load. I haven’t altered the functionality at all, just changed the maximum version number to 3.* and tested them. They work on my system but you use them at your own risk on yours.

Stop-or-Reload Button 0.2.2 — The page says it works up to Firefox 3.0 (but it doesn’t even do that). The Hacked version still works with Firefox 3.5.

UK Threat Level 0.16Hacked version 0.16.99

British English Dictionary 1.19 — The page says it works with Firefox 3.6 but it doesn’t. The Hacked version 1.19.99 still works with Firefox 3.5. This extension is also suitable for Thunderbird 2.*. It is not entirely clear if this dictionary is needed for Firefox 3+ or if there is one built into the English (British) basic download.

Google Pagerank Status 0.9.8 — Although the web site doesn’t say so, the version there is now 0.9.9 and does support Firefox 3 but not 3.5. Hacked version

Objection 0.3.3 doesn’t support Firefox 3.5 though they are working on a version 0.4. Update 6 Jul 2009: v0.3.4 is now available.

Minimize to Tray (Windows) doesn’t work with Firefox 3 — The Hacked version also works with Thunderbird 2.*.

Comments are closed.

^ Top